Simple Array Sum
Problem
Given an array of N integers, can you find the sum of its elements?
Input Format
The first line contains an integer, N, denoting the size of the array.
The second line contains N space-separated integers representing the array's elements.
Output Format
Print the sum of the array's elements as a single integer.
Sample Input
6
1 2 3 4 10 11
Sample Output
31
Solution
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
/* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
Scanner sc = new Scanner(System.in);
int size = sc.nextInt();
int sum = 0;
while(sc.hasNextInt()){
sum += sc.nextInt();
}
System.out.print(sum);
}
}
A Very Big Sum
Solution
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
/* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
Scanner sc = new Scanner(System.in);
int size = sc.nextInt();
long sum = 0;
while(sc.hasNextInt()){
sum += (long)sc.nextInt();
}
System.out.print(sum);
}
}