Problem
Given an array of integers, calculate which fraction of its elements are positive, which fraction of its elements are negative, and which fraction of its elements are zeroes, respectively. Print the decimal value of each fraction on a new line.
Note
This challenge introduces precision problems. The test cases are scaled to six decimal places, though answers with absolute error of up to are acceptable.
Input Format
The first line contains an integer, , denoting the size of the array.
The second line contains space-separated integers describing an array of numbers .
Output Format
You must print the following lines:
A decimal representing of the fraction of positive numbers in the array.
A decimal representing of the fraction of negative numbers in the array.
A decimal representing of the fraction of zeroes in the array.
Sample Input
6
-4 3 -9 0 4 1
Sample Output
0.500000
0.333333
0.166667
Solution
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
int pos = 0, neg = 0, zero = 0;
int[] A = new int[n];
for (int i = 0; i < n; i++) {
A[i] = in.nextInt();
}
for (int i = 0; i < n; i++) {
if (A[i] == 0) zero++;
else if (A[i] > 0) pos++;
else neg++;
}
System.out.println((float) pos / n);
System.out.println((float) neg / n);
System.out.println((float) zero / n);
}
}